настройка iptv от ростелеком на openwrt

Для настройки я использую веб-интерфейс luci. Выделим порт под приставку, если она есть, для этого нужно соединить порт wan с портом для приставки в bridge, делается это через VLAN.

40

vlan 1 — группа lan, vlan 2 — группа wan. В моем случае порт 1 это порт wan, 4 порт по факту 3, нужно перенести этот порт из vlan 1 в vlan 2. Для этого  указываем в vlan 2 значение «без тега», а в vlan 1 «выключено».

дальше ман о том как настроить iptv, чтобы иметь возможность смотреть его с пк/raspberry/телевизора/холодильника/кофеварки… и если вы не собираетесь смотреть с чего либо кроме iptv приставки то дальше можно не читать.

На ppoe соединении нет iptv, он живет прямо на wan интерфейсе, чтобы подключиться к мультикастовой группе нужно выдать ip wan интерфейсу, для этого якобы создадим интерфейс и привяжем его к vlan 2 и пропишем какой-нибудь ip, например 10.10.10.1, но по факту похоже без разницы какой ip выдать, шлюз прописывать не надо.

41

42

43

45

46

Мы все еще не сможем подключиться к мультикастовой группе, ибо находимся за nat, для работы iptv в nat используется igmpproxy.

Установка igmpproxy

Выполните команды устанавливающие igmpproxy:

opkg update; opkg install igmpproxy

После установки пакета, необходимо отредактировать файл конфигурации /etc/config/igmpproxy:

config igmpproxy
        option quickleave 1

config phyint
        option network iptv
        option direction upstream
        list altnet 224.0.0.0/4
        list altnet 82.208.79.0/24

config phyint
        option network lan
        option direction downstream

Настройки Firewall

Вы так же должны разрешить IGMP для WAN интерфейса и перенаправить широковещательный трафик следующими правилами в файле /etc/config/firewall:

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

Запуск igmpproxy

После добавления правил, необходимо перезапустить фаервол, добавить igmpproxy в автостарт и естественно запустить сам igmpproxy. Выполните следующие команды:

# /etc/init.d/firewall restart
# /etc/init.d/igmpproxy enable
# /etc/init.d/igmpproxy start

В дальнейшем igmpproxy будет сразу стартовать автоматически в процессе загрузки роутера.

Подсети провайдера из которых идет вещание

Если вы не уверены, что надо написать в строках list altnet файла конфигурации /etc/config/igmpproxy, то закомментируйте эти строки и посмотрите на вывод igmpproxy в логе роутера. Пытайтесь после запуска igmpproxy подписываться на какие-либо каналы с помощью VLC или каким-нибудь другим клиентом (проигрывателем). Если в файле конфигурации не будет хватать сетей, то вы увидите в логе, что-то типа: «Warn: The source address 10.254.16.66 for group 233.32.240.222, is not in any valid net for upstream VIF». Таким образом вы узнаете широковещательный адрес вашего провайдера и сможете добавить необходимую подсеть в файл конфигурации /etc/config/igmpproxy.

network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdef:106b:cb4f::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘wan’
option ifname ‘eth0.2’
option _orig_ifname ‘eth0.2’
option _orig_bridge ‘false’
option proto ‘pppoe’
option username ‘***’
option password ‘***’
option peerdns ‘0’
option dns ‘77.88.8.1 77.88.8.8’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 2 3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0t 1 4’
option vid ‘2’

config interface ‘wan6’
option proto ‘6to4’

config interface ‘iptv’
option proto ‘static’
option ifname ‘eth0.2’
option ipaddr ‘10.10.10.1’
option netmask ‘255.255.255.0’
option delegate ‘0’
option auto ‘0’

[свернуть]

настройка iptv от ростелеком на openwrt: 27 комментариев

  1. Не могли бы выложить сюда конфиг /etc/config/network. В начале не совсем наглядно, откуда появились eth0.1 eth0.2 eth0.3


    1. /etc/config/network

      config interface 'loopback'
      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

      config globals 'globals'
      option ula_prefix 'fdef:106b:cb4f::/48'

      config interface 'lan'
      option ifname 'eth0.1'
      option force_link '1'
      option type 'bridge'
      option proto 'static'
      option ipaddr '192.168.1.1'
      option netmask '255.255.255.0'
      option ip6assign '60'

      config interface 'wan'
      option ifname 'eth0.2'
      option _orig_ifname 'eth0.2'
      option _orig_bridge 'false'
      option proto 'pppoe'
      option username '****'
      option password '****'
      option peerdns '0'
      option dns '77.88.8.1 77.88.8.8'

      config switch
      option name 'switch0'
      option reset '1'
      option enable_vlan '1'

      config switch_vlan
      option device 'switch0'
      option vlan '1'
      option ports '0t 2 3 5'
      option vid '1'

      config switch_vlan
      option device 'switch0'
      option vlan '2'
      option ports '0t 1 4'
      option vid '2'

      config interface 'wan6'
      option proto '6to4'

      config interface 'iptv'
      option proto 'static'
      option ifname 'eth0.2'
      option ipaddr '10.10.10.1'
      option netmask '255.255.255.0'
      option delegate '0'
      option auto '0'

      1. проблема в том что у меня не ростелеком. в сети не нашел плайлист своего провайдера. Как самому найти, сделать плейлист?

        1. Этого я не знаю, самому интересно, теоретически нужно перебрать все адреса сети, вручную это нереально, нужна какая-то софтина

          1. Почему не реально? В СпидиЛайн 255 адресов всего перебрать. Так они каналы еще не шифруют. Очень даже хороший плейлист получился

  2. Подскажите пожалуйста, у меня в настройках switch0 не виден wan порт, видны только cpu и lan-порты, как сделать чтобы его увидеть И в настройках канала wan порт идет как ethernet adapter ‘eth1’. Либо может мне тогда объединять порты в bridge как-то по-другому?

    1. У меня тоже не виден, с его точки зрения они все просто порты одного свитча, 1,2,3 и т.д.
      Методом не научного тыка я понял что первым был wan
      Например у asus rt n12 они были ещё и в обратном порядке

  3. У меня netgear wndr3700v2 (ethernet + 4 lan порта) и у меня тоже нумерация идет в обратном порядке, при этом такой порядок: cpu, порт4 (всегда отключен, хз что это), порт3 (начинается lan) и еще 3 lan порта. У Вас на скриншоте видно, что к wan порту подключен кабель, у меня же подключен только один lan порт (приставка тв), остальные 3 пустые, т.е. вариантов для поиска wan нету :-(

    1. а интернет то вы как настраиваете? мне для pppoe соединения нужно указать vlan в котором wan порт, и кажется этот vlan у меня был с самого начала, хотя я не помню…
      на крайняк можно использовать вместо wan любой другой порт, так же врубив его в отдельном vlan и так он станет в роли wan, ну например если физически порт выгорит

  4. Инет настраивается просто через pppoe (также как у Вас, судя по скрину), создается интерфейс через pppoe протокол (vlan не используется) и в физических настройках выбирается ethernet adapter (eth1) (писал выше, у Вас на картинке такого нет). В том и вопрос, что это особенность этого роутера и как его запилить (если это возможно конечно) под наши реалии, в частности ростелеком

  5. И кстати чем отличается постройка моста описанного Вами, от того если при создании нового интерфейся (iptv, например) в настройках канала ставить галку создания моста и выбирать мой ethernet adapter (wan) или это не тоже самое? Заранее извиняюсь за дилетанские вопросы :-)

    1. Полагаю это уже относится к соединению разных сетевушек, и это то что нужно, но проверить мне не на чем

  6. Ну у меня этот свитч это eth0, eth0.1 и 0.2 это какраз таки vlanы, если у вас есть и eth0 и eth1 то это явно разные сетевушки, а это окно настройки коммутатора относится только к одной из них

  7. Здравствуйте! Не могли бы вы помочь настроить IPTV приставки Ростелекома на роутере с прошивкой OpenWRT (TP-Link WRD4300), для этого нужно знать VLAN? Знаний на перепрошивку и первоначальную настройку роутера у меня хватило, на установку соединения с интернетом ПК по кабелю тоже, а вот поднять IPTV приставки не получается. В моем случае 3 приставки 2/3/4 порты. Причина по которой пришлось переходить с официальной прошивки на OpenWRT в том, что на оф. для IPTV можно назначить только 2 порта.

    1. если порт wan и порты для приставки являются одной сетевушкой то нужно порт wan и нужный порт для приставки включить в один vlan, таким образом получится мост

  8. Подскажите… У меня иптв подключается по тегированному влан, инет по pppoe. Стоит только создать подключение для иптв, пропадает инет. Что я делаю не так?

  9. Подскажите пожалуйста, у меня такая схема: оптический терминал + роутер тп-линк 1043nd. У оптического терминала 2порта для интернета и 2порта iptv.
    Интернет — поднимается через PPPoE, а iptv мост. Можно ли выделить какой-нибудь из ланов роутера под ван и туда направить иптв из теминала. Чтобы в итоге на оставшихся ланах были интернет+иптв.

  10. Здравствуйте.

    Мои VLANID тэги которым ростелеком сплитит трафик имеют значения что то типа 501 для TV и 300 для интернета. Всё успешно работает на Zyxel, но никак не могу разобраться с OpenWrt. Где мне задать эти значения тэгов.
    В разделе Switch в качестве VLAN ID мне интерфейс позволяет ввести только значения от 1 до 15.
    Где задаются тэги? Возможно что мой роутер не поддерживает такие значения для VLANID?

  11. та же самая беда VLAN ID (VID) не даёт прописать более 15 / а надо 1601 — это VID Ростелекома (то есть кольца VLAN-а)

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *